Отзыв о сайте
Реклама
Форум
Иконка Windows Movie Maker

Windows Movie Maker

Версия для Windows.
Вопросы и ответы по «Windows Movie Maker»
🔍

Воспроизведение в шкале времени и сохранение

Добрый день, господа. Возникла такая проблема.
Windows 7, файловая система NTFS, оперативная память 1 Гб, Movie Maker 2.6. Клип в Windows Movie Maker готов. Однако при воспроизведении его в шкале времени в один определённый момент воспроизведение останавливается, как если бы была нажата пауза. Если снова нажать "Воспроизвести", клип продолжает играть.
Однако из-за этого готовый фильм не хочет сохраняться. Сначала сохранение идёт нормально, но когда (на глаз если смотреть, по процентам) сохранение доходит до этого "странного" момента, который останавливает клип, выдаётся сообщение: "Программе Windows Movie Maker не удаётся сохранить фильм в указанной папке..." - стандартное сообщение об ошибке при сохранении.
Исходное видео для клипа в формате WMV. За время создания клипа даже не тормозило и не вылетало. Конечный клип получился длиной в 2 минуты.
Проблема именно в видео: я пробовала убирать звук, оставив только видео, и оно всё равно останавливалось. Если убирать видео, оставляя звук, остановка не происходит.
Места на диске более чем достаточно. Диск, на который пытаюсь сохранять, не системный, прописанный путь сохранения содержит только латинские символы.
Файлы, естественно, все на месте, иначе бы и просмотра на шкале времени не было Well
Я просмотрела весь форум и испробовала все рекомендации:
- Убрала все флажки в настройках "Совместимость" (хотя с этим никогда не было проблем)
- Пыталась менять размер файла подкачки
- Делила ролик на две части - два разных проекта. Всё равно останавливается в том же кадре, фильм не сохраняется
- Запускала от имени администратора
- Меняла параметры сохранения - размеры и качество конечного файла
- Переустанавливала Movie Maker и K-Lite Codec Pack (по 2 раза) по рекомендациям и ссылкам с этого форума
- Копировала все файлы в новый проект

И всё равно никакого результата.

Возможно, дело всё-таки, в K-Lite? Какие именно настройки стоит указать при его установке?

Буду очень благодарна вам за помощь.
     08.02.2014 22:54 · Просмотров:
0
0

Ответы на вопрос :

Сортировать по:
времени
Sergio87 (19871) 09.02.2014, 13:32
0
0
Ух, какой длинный вопрос... Если честно, мои подозрения падают на объём оперативной памяти. Его даже для комфортной работы семёрки (с её интерфейсом Aero) маловато будет. А что касается работы с видео, так там ещё более высокие запросы.

Можете указать более подробные данные о видеофайлах, используемых в Вашем проекте? Если таковых несколько, то особого внимания заслуживает тот фрагмент, на котором как раз и возникает пауза.

K-Lite Codec Pack обычно ставится с настройками по умолчанию. Потому что, прежде, чем что-то в них менять, нужно отчётливо понимать, какая настройка за что отвечает.

Как вариант, можно попробовать перекодировать проблемный видеофрагмент в любой другой формат. Быть может, после этого Ваша проблема исчезнет.
Гость#91096 09.02.2014, 15:00
0
0
Sergio87, спасибо за ответ!
В клипе используются два файла: один полный фильм (3 часа 39 минут) и в самом конце фрагмент из короткого видео (1,5 минуты). Оба фильма в формате *.WMV, переведены в этот формат в одном и том же конвертере.
Пауза возникает как раз в фрагменте из большого фильма. Я пробовала менять фрагмент, ставить другой (из того же фильма) - проблема остаётся.

K-Lite я ставила и со своими настройками, и с "по умолчанию", результат тот же.

За этим компьютером работаю уже (страшно сказать) почти 6 лет, проблем с Movie Maker никогда не было. Оперативная память оставалась той же все эти годы. Хотя, конечно, машина старовата Not so

С исходным фильмом (не переведённым в *.WMV) прога отказывается работать (зависает, вылетает при попытке добавить эффект, обычные глюки Movie Maker). Её можно понять: фильм большой, в формате *.AVI, весит 4,5 гига, 4 звуковых дорожки... Поэтому я перевела его в более удобный для Movie Maker *.WMV, и все нормально - за всё время создания клипа ни разу не затормозил, не завис, не вылетел. Только вот эта "остановка" всё портит. Не могу понять причину.

Попробую перевести этот фильм снова в *.AVI и на этот раз без звука - глядишь, поможет. Хотя я не уверена, что проект прочитает этот фильм и добавит его уже в готовую шкалу времени. Но попробую Well
Гость#91097 09.02.2014, 15:23
0
0
Более подробное инфо о видео.

Большой фильм:
General
Format : Windows Media
File size : 1.30 GiB
Duration : 3h 39mn
Overall bit rate : 849 Kbps
Maximum Overall bit rate : 832 Kbps
Description : 29.06.2011
Encoded date : UTC 1970-01-01 00:00:00.000
WM/EncodingSettings : Lavf54.6.100

Video
ID : 1
Format : WMV2
Codec ID : WMV2
Codec ID/Info : Windows Media Video 8
Description of the codec : wmv2
Duration : 3h 39mn
Bit rate : 743 Kbps
Width : 720 pixels
Height : 304 pixels
Display aspect ratio : 2.35:1
Frame rate : 25.000 fps
Bit depth : 8 bits
Bits/(Pixel*Frame) : 0.136
Stream size : 1.14 GiB (87%)

Audio
ID : 2
Format : WMA
Format version : Version 2
Codec ID : 161
Codec ID/Info : Windows Media Audio
Description of the codec : Windows Media Audio V8
Duration : 3h 39mn
Bit rate : 63.9 Kbps
Channel(s) : 2 channels
Sampling rate : 48.0 KHz
Bit depth : 16 bits
Stream size : 100 MiB (8%)

Маленькое видео (фрагмент в конце клипа):
General
Format : Windows Media
File size : 12.3 MiB
Duration : 1mn 59s
Overall bit rate : 862 Kbps
Maximum Overall bit rate : 832 Kbps
Encoded date : UTC 1970-01-01 00:00:00.000
WM/EncodingSettings : Lavf54.6.100

Video
ID : 1
Format : WMV2
Codec ID : WMV2
Codec ID/Info : Windows Media Video 8
Description of the codec : wmv2
Duration : 1mn 59s
Bit rate : 755 Kbps
Width : 480 pixels
Height : 272 pixels
Display aspect ratio : 16:9
Frame rate : 25.000 fps
Bit depth : 8 bits
Bits/(Pixel*Frame) : 0.231
Stream size : 10.7 MiB (88%)

Audio
ID : 2
Format : WMA
Format version : Version 2
Codec ID : 161
Codec ID/Info : Windows Media Audio
Description of the codec : Windows Media Audio V8
Duration : 1mn 59s
Bit rate : 63.9 Kbps
Channel(s) : 2 channels
Sampling rate : 48.0 KHz
Bit depth : 16 bits
Stream size : 932 KiB (7%)

Аудио (песня, которая используется для клипа):
General
Format : Windows Media
File size : 2.12 MiB
Duration : 2mn 17s
Overall bit rate mode : Variable
Overall bit rate : 129 Kbps
Maximum Overall bit rate : 138 Kbps
Encoded date : UTC 2014-02-02 12:07:33.819
Application : Windows Movie Maker 2.6.4037.0

Audio
ID : 1
Format : WMA
Format version : Version 2
Codec ID : 161
Codec ID/Info : Windows Media Audio
Description of the codec : Windows Media Audio 9.2 - VBR Quality 75, 44 kHz, stereo 1-pass VBR
Duration : 2mn 17s
Bit rate mode : Variable
Bit rate : 128 Kbps
Channel(s) : 2 channels
Sampling rate : 44.1 KHz
Bit depth : 16 bits
Stream size : 2.10 MiB (99%)
Language : English (US)
Гость#91116 09.02.2014, 19:48
0
0
Переводила фильм в *.AVI, проект его не принял. Конечно, видео же в другом формате, другого размера... Можно заново переделать, но уже ведь не то будет, там много точно нарезанных клипов и эффектов.
Попробую последний вариант - все материалы сохранить и попробовать записать фильм на другом компьютере. Если не пойдёт, значит, пропал клип Not so
Sergio87 (19871) 10.02.2014, 06:27
0
0
Знаете, какие у меня мысли возникли? Судя по приведённым медиаданным, Вы используете кодек Windows Media Video 8. Но ведь это устаревшая версия (Windows Media Video). Я бы попробовал обновить версию проигрывателя (или чем Вы там конвертируете видео) и попробовать снова перегнать в avi (разумеется, исходный качественный файл).

Ещё смущает, что видеофрагменты Вы используете с разным разрешением. Но судя по тому, что заедание приходится на большой эпизод, то проблема всё-таки не в этом.
Гость#91181 10.02.2014, 21:47
0
0
Пробовала вроде переводить, никак...

Я решила проблему иначе! Записала клип в Movie Maker с экрана с помощью Camtasia! И не мучилась. Теперь клип готов.

Ещё раз спасибо за то, что уделили мне время и внимание. Удачи вам всем. Sergio87 отдельное спасибо за оперативность и желание помочь. Всех благ.
Sergio87 (19871) 11.02.2014, 05:59
0
0
Изобретательное решение Вы нашли. Качество при этом не пострадало? Бесспорно, Ваше решение будет полезным для многих пользователей, поскольку аналогичная проблема возникает очень часто.
Гость#91289 11.02.2014, 20:50
0
0
Будешь тут изобретательным, когда пропадает твое творчество, за которое сражаешься с собственным компом 2 недели Well))

Качество пострадало не сильно. Терпимо, я бы сказала. Конечно, хотелось бы лучше, но это не самое главное Well Полезный совет: если сильно тормозит при вопроизведении в Movie Maker, сжимайте окно, в котором идёт клип - чем меньше периметр рамки и изображение, тем легче ему показывать Well
Sergio87 (19871) 12.02.2014, 04:58
0
0
Вообще, для комфортной работы с видеоредкторами необходимо железо помощнее. Это Windows Movie Maker ещё не такой требовательный. Но у него и функционал ограничен весьма. Тот же Pinnacle ресурсы кушает с превеликим аппетитом.
Гостьp#105712 04.08.2014, 14:04
0
0
Не знаю смогу ли я помочь, но я столкнулся с подобной проблемой
(Для меня это был шок):

Обычная презентация: фото, текст, много текста, лого в векторе (звук накладываю в соундфордже после рендера) проект в HD 300 сек.

Железяка лэйт 2013 МБП, 16Г, 2,3Х, дискрет, места свободного 20% на ссд


Разбил на сцены текста, и ворочу.
На заголовки сделал аниматор класный (много ключей и се такое) – это стиль и концепт, и тут лопатой по горбу получил когда дошел до второго заголовка.

Возвращаюсь к первому заголовку что бы скопировать аниматор и положить на следующий текст.

Копи, паст и тут опачки!!!! При просмотре (пробелоплэй) на 10-15 кадре (всегда по разному если воспроизводить с самого начала композиции) просто пауза, текст (аниматор) не показывает заложенный в него ключеаниматор. Долблю на пробел, и с каждым нажатием останавливается бегунок на следующем кадре. Проматываю чуть далее, такая же хрень. Все нормально где то спустя 50 кадров от последнего ключа аниматора, НО на овер-ключах аниматора срабатывает просмотр и тд.
Вручную пересоздать аниматор такая же балалайка.
Вот боюсь теперь трогать первый заголовок.

Решение простое – удаляю текстовой СЛОЙ и все работает
(если удалить просто ключи или аниматор – не помогает, все равно стопорится)

Думал проблема в кэшэ, перезагружался не помогло.... Решения в инете не нашел.

ЗЫ Хорошо что я нашел в чем проблема сразу, и вот сейчас будут выдумывать новый аниматор, и надеюсь он везде будет работать. Если повторится с другими, значит лажа в самом ядре аниматора (как то так))) Отпишусь.

Всем добра!
Вопрос и ответы были вам полезны?   Да    Нет
Попробуйте также:

Похожие вопросы:

Добавить ответ

Ваше имя:

Регистрация? Это возможность подписаться на новые ответы, получать за ответы очки и призы
Маты, сообщения БОЛЬШИМИ БУКВАМИ, с грубыми ошибками, просто глупые и совершенно не по теме будут удаляться.

Спасибо, что Вы с нами.
В ответ на сообщение Нет
+ Фото
Текст с картинки